New Critical Vulnerabilities in Drupal